iphone-software-update-301


От Apple пуснаха супер експресен ъпдейт на фирмуера версия 3.0.1 за всички модели iPhone, като идеята му е само и единствено да оправи потенциалния проблем в SMS функционалността на телефоните. Това се случва само ден по-късно след публичното обявяване на открития пробив в сигурността на SMS функционалността на фирмуер 3.0 по време на посветената на сигурността конференция Black Hat в Лас Вегас. Похвално, че от Apple реагират толкова бързо, оправяйки тази потенциално сериозна дупка в сигурността на телефона, макар от компанията да заявяват, че в действителност никой не е успял още да се възползва от този експлоит, за да поеме контрол над чужд телефон…

Не бързате да обновявате своите телефони към новия фирмуер 3.0.1 (нормалния съвет, особено за нови потребители), защото това ще доведе до загуба на достъпа до файловата система (jailbreak) и разбира се ще заключи отново устройствата, които не са фабрично отключени (както се получава при всеки един ъпдейт!). И все пак добрата новина е, че няма нужда да чакате, за да имате възможност да направите jailbreak на 3.0.1 и в последствие да отключите GSM функционалността на своите устройства ако вече сте ъпдейтнали или планирате да го направите. На практика redsn0w версия 0.8 може да jailbreak-не и новия 3.0.1 фирмуер с една малка особеност, а именно, че след ъпдейта на телефона през iTunes до 3.0.1 трябва да пуснете redsn0w и от него да изберете фирмуер 3.0. Това е така, защото тази версия на redsn0w не разпознава новия фирмуер, но няма никакъв проблем да изберете 3.0 в програмата, при което ще получите безпроблемно джейлбрейкнат телефон с фирмуер 3.0.1. Разбира се от iPhone Dev-Team ще пуснат ъпдейт на redsn0w, но идеята е, че не е нужно да чакате такъв, за да може да направите jailbreak на своето устройство дори в момента, а след jailbreak-а спокойно може да инсталирате и ultrasn0w 0.9, за да отключите GSM функционалността. Това на практика е другата добра новина, тъй като реално новия фирмуер 3.0.1 не пипа нищо по бейзбенда на телефона, съответно и ultrasn0w 0.9 се инсталира и работи без никакви грижи на него.