От iPhone Dev Team пуснаха новата версия 1.2.4 на Ultrasn0w в своето repository в Cydia, която официално поддържа iOS 5.0, като единствената новост е поддръжката за новата версия на мобилната операционна система на Apple, все още няма поддръжка за по-нови бейзбенди спрямо предходната версия на софтуер. Ultrasn0w е инструмент за софтуерно отключване на iPhone, който позволява на телефони, заключени към даден мобилен оператор да използват SIM карти и на други оператори свободно. Тъй като обаче този софтуер изисква джейлбрейкнато устройство (с отключен пълен достъп до файловата система), то използването на Ultrasn0w 1.2.4 под iOS 5.0 все още е проблемно. Причината е, че за момента само собствениците на iPhone 3G със стар бутром разполагат с untethered jailbreak (постоянен), а за всички останали е наличен само tethered jailbreak (необходимо е да прилагате наново джейлбрейка всеки път след рестартиране на устройството). Не забравяйте и че за да може да използвате Ultrasn0w 1.2.4 е необходимо да направите ъпдейт към iOS 5.0 с преработен фирмуер, който няма да обнови и бейзбенда на телефона, а не с официалната версия на iOS 5.0!